Issue logging into mobile app
Incident Report for Billy
Resolved
The issue has been resolved.
Posted over 3 years ago. Feb 24, 2016 - 10:44 CET
Identified
We've identified an issue preventing some users from accessing the mobile app. We're working on a solution, and expect the issue to be resolved shortly.
Posted over 3 years ago. Feb 24, 2016 - 09:19 CET