Degraded performance
Incident Report for Billy
Resolved
We have resolved the issue. Service is now operational under normal conditions.
Posted almost 2 years ago. Oct 02, 2017 - 16:24 CEST
Investigating
We are currently experiencing degraded performance with our backend services. We are investigating the issue and working on a fix.
Posted almost 2 years ago. Oct 02, 2017 - 13:30 CEST