Service outage
Incident Report for Billy
Resolved
This incident has been resolved.
Posted about 3 years ago. Jan 20, 2016 - 12:17 CET
Monitoring
The issue has been fixed. We are monitoring the situation closely.
Posted about 3 years ago. Jan 20, 2016 - 09:45 CET
Identified
Large parts of our system are unavailable at the moment. We've found the issue and are working to fix it as soon as possible.
Posted about 3 years ago. Jan 20, 2016 - 09:04 CET