Central parts of our system is down, due to network outage
Incident Report for Billy
Resolved
This incident has been resolved.
Posted almost 3 years ago. Jun 20, 2016 - 18:39 CEST
Monitoring
It seems that we're recovering from the issue. We are monitoring the situation.
Posted almost 3 years ago. Jun 20, 2016 - 15:12 CEST
Investigating
We are currently experiencing some upstream network issues in parts of Europe, which mitigates the ability to access Billy.
Posted almost 3 years ago. Jun 20, 2016 - 14:47 CEST